By: Gonzalo Acosta | October 16, 2017

Validación de Datos Valores Únicos

Fórmula genérica
=CONTAR.SI(RANGO,A1)<2

Explicación
Para permitir solo valores únicos en un rango determinado, puede usar la validación de datos con una fórmula personalizada basada en la función CONTAR.SI. En el ejemplo que se muestra, la validación de datos aplicada a C5:C13 es:
=CONTAR.SI(correo,C5)<2)

Donde "correo" es el nombre de rango de las celdas C5:C13.
Cómo funciona esta fórmula
Las reglas de validación de datos se activan cuando el usuario agrega o cambia un valor de la celda. En este ejemplo, estamos utilizando una fórmula que comprueba que la entrada no existe en el rango "correo".
=CONTAR.SI(correo,C5)<2

CONTAR.SI devuelve la cantidad de veces que el valor de la celda C5 aparece en el rango "correos" que está formado por las celdas (C5:C13). Si el resultado es menor que 2, la expresión devuelve VERDADERO y la validación tiene éxito. De lo contrario, la expresión devuelve FALSO y la validación falla.

Descargue el archivo aquí:

Validación de Datos Valores Únicos

Category: Uncategorized 

Tags:

Comments:

Be the first to comment ...

Post a Comment